אופן אופיס/שימוש בביבליוגרפיה

תוכנת ה-Writer כוללת בתוכה יישום האחראי למאגר נתונים של ביבליוגרפיה.

שימו לב: על מנת להשתמש במאגר ביבליוגרפיה גלובלי, תוכנת ה-Base חייבת להיות מותקנת!

ניתן לעבוד עם רשימת ביבליוגרפיה בשני אופנים:

  1. לתחזק מסד נתונים ביבליוגרפי גלובלי, אשר מאוחסן בברירת המחדל ב:
    (לינוקס) /usr/lib/openoffice/presets/database/biblio.odb
    (חלונות) C:\Program Files\OpenOffice.org\..?
  2. ליצור רשימת מקורות נפרדת עבור כל מסמך (באופן זה אין צורך בתוכנת ה-base). שימו לב כי לא תוכלו להשתמש באופן "שקוף" בין מקורות שהזנתם לשני מסמכים שונים, אלא תצטרכו להזין אותם מחדש.
  3. שילוב: ניתן להוסיף לאותו מסמך הן מקורות בלעדיים והן מקורות ממסד הנתונים הגלובלי. שימו לב כי למקורות הבלעדיים יש קדימות (מבחינת התוכנה) על פני מקורות ממדס הנתונים.

הוספת מקור למסמךעריכה

  1. מקמו את הסמן במקום בו צריך להוסיף סימוכין, וגשו אל:
    Insert->Indexes and Tables -> Bibliography Entry...
  2. בחלון שנפתח סמנו "From document content".
  3. לחצו על New ומלאו את פרטי המקור. לבסוף לחצו על OK.
    • שימו לב שהנכם מסמנים נכונה את סוג (Type) המקור.
    • חשוב מלא את השדה "Short name", שכן זאת תהיה מחרוזת הזיהוי של המקור, ושאותה תצטרכו לבחור מתוך רשימה כאשר תרצו להוסיף הפנייה למקור זה.
  4. מתוך הרשימה הנגללת בחרו המקור המתאים ולחצו על "Insert".

כעת המקור נשמר ובאפשרותכם לשנות מספר הגדרות:

  1. לחצו עם לחצן העכבר הימני על השדה האפור שהתווסף ובחרו ב-"Bibliography Entry...".
  2. כעת באפשרותכם לשנות את פרטי המקור.

אחרי שהכל מוכן, יש להוסיף את סעיף המקורות, כמתואר למטה.

הוספת מקורות למאגר הביבליוגרפיהעריכה

  1. גשו ל: Tools->Bibliography Manager.
  2. בחלון הנפתח לחצו על: Insert->Record.
  3. מלאו את הפרטים הדרושים לכם, והתעלמו מן השאר. שימו לב כי הכניסה "Short name" הינה חיונית. כאשר תרצו להוסיף הפניה לביבליוגרפיה, זהו הערך שתצטרכו למצוא מתוך רשימה.
  4. לאחר שהזנתם את כל הפרטים הדרושים, סגרו את החלון.

הוספת רשימת מקורותעריכה

רשימת המקורות תופיע בדרך כלל בסוף המסמך.

  1. מקמו את הסמן במקום הרצוי וגשו ל: Insert->Indexes and Tables->Indexes and Tables.
  2. בכרטיסיה Index/Table כתבו "מקורות" או כל דבר אחר ליד המילה "Title", וברשימה ליד המילה "Type" בחרו ב-"Bibliography". אם ברצונכם לקבל רשימה ממוספרת, יש לסמן את "Numbered entries". כמו כן ניתן לבחור את סוג הסוגריים אשר יופיעו ליד הפניות. כדאי להסיר את הסימון מהאפשרות "Protect against manual changes".
  3. בכרטיסיה Entries יש לבחור את הפורמט של הביבליוגרפיה, כפי שהיא תופיע במסמך. עבור כל סוג מקור שהנכם מתכננים להשתמש בו במסמך (ברשימה מתחת למילה Type) יש לבצע את השלבים:
  1. מול המילה Structure מופיעות הכניסות "Sh", "Au", "Ti", "Ye", המופרדים באמצעות סימני פיסוק (אלו הם קיצורים עבור שם-מקוצר, מחבר, כותרת, שנה). ביכולתכם לשנות את המבנה על ידי הוספת פרטים מהרשימה ולחיצה על Insert.
  2. על מנת למחוק פרטים, כמו למשל את Short name, יש ללחוץ עליו ולאחר מכן על Remove.
  1. יש ללחוץ על OK (קיימות עוד אפשרויות רבות, אך השימוש בהן מעט מסובך ולא נכנס לזה).

למסמך התווספה כותרת עם השם שבחרתם עם רקע אפור. הרקע האפור מעיד על כך שזהו שדה מיוחד. תוכנת ה-Writer תנהל מספור אוטומטי של המקורות עבורכם.

הוספת הפניה למקורעריכה

כאשר הינכם מוסיפים טקסט ורוצים להפנות אל מקור לאחר שכבר קיימת כניסה עבורו במאגר הביבליוגרפיה, ניתן לבצע זאת בשלבים הבאים:

  1. מקמו את הסמן ליד הטקסט שנלקח מהמקור.
  2. גשו ל: Insert->Indexes and Tables->Bibliography entry.
  3. מתחת למילה Entry סמנו את "From bibliography database".
  4. ברשימה מתחת למילה Short name בחרו במקור שאותו הוספת מבעוד מועד, ולחצו על Insert.

כעת הופיע מספר בסוגרים (אשר את סוגם יכולתם לבחור קודם). על מנת שהמקור יופיע ברשימה יש ללחוץ על הכפתור הימני של העכבר במקום כלשהו בשדה הביבליוגרפיה וללחוץ על "Update Index/Table".

קישורים חיצונייםעריכה